Программирование - это просто
Advertisement
Главная arrow 1С:Предприятие arrow Разные статьи по 1С arrow 1С 8.3. Оповещение пользователя.
18.08.2017 г.
Главное меню
Главная
Системный подход
Интернет магазин
Биржевые роботы
Программные продукты
Математика и информатика
1С:Предприятие
C#, Delphi, VB, F#, Web и пр.
Искусственный интеллект
Услуги
Ча. Во. (FAQ)
Платный раздел
Наука для чайников
Разное
Размышления
Карта сайта
Друзья сайта
Excel-это не сложно
Все о финансах
1С 8.3. Оповещение пользователя. Печать E-mail
Автор megabax   
27.05.2017 г.
New Page 1

1С 8.3. Оповещение пользователя.

См.  также Изучаем 1С 8.2. Урок 24. Сообщения пользователю, 1C 8.2 и 8.3 (УФ). Для чайников (платный раздел), 1C 8.2 Для чайников (бесплатный раздел)

Сегодня мы рассмотрим такой механизм 1С, как оповещение пользователя. Что это такое. Допустим, мы записываем элемент справочника и видим такое вот исчезающее сообщение в левом нижнем углу экрана:

1С 8.3. Оповещение пользователя.

Как сделать такое самостоятельно? Для этого можно воспользоваться процедурой ПоказатьОповещениеПользователя(), например:

1С 8.3. Оповещение пользователя.

Вот результат работы данной программы:

1С 8.3. Оповещение пользователя.

В стандартном оповещении есть ссылка, если мы кликнем на нее, то у нас эта ссылка откроется:

 1С 8.3. Оповещение пользователя.

Мы тоже можем сделать подобную ссылку, для этого нам надо всего лишь установить второй и третий параметр процедуры ПоказатьОповещениеПользователя():

&НаСервере
Функция ПолучитьСсылкуНаСправочник()
        возврат Справочники.Номенклатура.НайтиПоКоду("000000001");
КонецФункции


&НаКлиенте
Процедура Команда1(Команда)
        спр=ПолучитьСсылкуНаСправочник();
        Ссылочка=ПолучитьНавигационнуюСсылку(спр);
        ПоказатьОповещениеПользователя("Hello, World!", Ссылочка, строка(спр));
КонецПроцедуры

Во втором параметре мы указываем саму ссылку, для получения навигационной ссылки от ссылки на объем используем функцию ПолучитьНавигационнуюСсылку(). Третий параметр - это текст ссылки, в нашем случае это наименование элемента справочника, который откроется по ссылке.

Вот что у нас в итоге получиться:

1С 8.3. Оповещение пользователя.

Если ссылку не указать, то в качестве третьего параметра будет просто  пояснение:

1С 8.3. Оповещение пользователя.

В качестве четвертого параметра можно указать картинку:

&НаКлиенте
Процедура Команда1(Команда)
        спр=ПолучитьСсылкуНаСправочник();
        Ссылочка=ПолучитьНавигационнуюСсылку(спр);
        ПоказатьОповещениеПользователя("Hello, World!", Ссылочка, строка(спр),БиблиотекаКартинок.ОбщаяКартинка1);
КонецПроцедуры

Создать картинку можно в конфигураторе в ветке "Общие картинки":

1С 8.3. Оповещение пользователя.

Картинку можно тупо загрузить из файла:

1С 8.3. Оповещение пользователя.

И вот что у нас в итоге получиться:

1С 8.3. Оповещение пользователя.

См.  также Изучаем 1С 8.2. Урок 24. Сообщения пользователю, 1C 8.2 и 8.3 (УФ). Для чайников (платный раздел), 1C 8.2 Для чайников (бесплатный раздел)


Скриншоты, опубликованные в данной статье, являются цитатами и иллюстрациями   программного продукта "1C:Предприятие версия 8.2", авторское право на который принадлежит ЗАО 1С.. 


 

Последнее обновление ( 27.05.2017 г. )
 
Пред. »
 
© 2017 Программирование - это просто
Joomla! - свободное программное обеспечение, распространяемое по лицензии GNU/GPL.
Русская локализация © 2005-2008 Joom.Ru - Русский Дом Joomla!
Design by Mamboteam.com | Powered by Mambobanner.de
Я принимаю Яндекс.Деньги
Мы принимаем
Банковские карты
Оплатите покупку в интернет-магазине банковскими картами VISA и Mastercard любого банка.
узнать больше
Электронный кошелек
Моментальная оплата покупок с помощью вашего электронного кошелька RBK Money.
узнать больше
Банковский платеж
Оплатите покупку в любом российском банке. Срок зачисления средств на счет - 3-5 рабочих дней.
узнать больше
Денежные переводы
Оплата покупок через крупнейшие системы денежных переводов CONTACT и Unistream.
узнать больше
Почтовые переводы
Оплатите покупку в любом отделении Почты России. Срок зачисления платежа - 3-4 рабочих дня.
узнать больше
Платежные терминалы
Оплата покупок в терминалах крупнейших платежных систем в любом городе России - быстро и без комиссии.
узнать больше