Программирование - это просто
Advertisement
Главная arrow 1С:Предприятие arrow Разные статьи по 1С arrow 1С 8.3. Оповещение пользователя.
01.12.2020 г.
Главное меню
Главная
Интернет магазин
Программные продукты
Биржевые роботы
Искусственный интеллект
Математика и информатика
1С:Предприятие
Уроки C#
Уроки Delphi
Уроки программирования
Web-программирование
Дизайн и графика
Компьютер для блондинок
Исходники
Статьи
Платный раздел
Рассказы про компьютеры
Хитрости и секреты
Системный подход
Размышления
Наука для чайников
Друзья сайта
Excel-это не сложно
Все о финансах
1С 8.3. Оповещение пользователя. Печать E-mail
Автор megabax   
15.11.2020 г.
New Page 1

1С 8.3. Оповещение пользователя.

См.  также Изучаем 1С 8.2. Урок 24. Сообщения пользователю, 1C 8.2 и 8.3 (УФ). Для чайников (платный раздел), 1C 8.2 Для чайников (бесплатный раздел)

Сегодня мы рассмотрим такой механизм 1С, как оповещение пользователя. Что это такое. Допустим, мы записываем элемент справочника и видим такое вот исчезающее сообщение в левом нижнем углу экрана:

1С 8.3. Оповещение пользователя.

Как сделать такое самостоятельно? Для этого можно воспользоваться процедурой ПоказатьОповещениеПользователя(), например:

1С 8.3. Оповещение пользователя.

Вот результат работы данной программы:

1С 8.3. Оповещение пользователя.

В стандартном оповещении есть ссылка, если мы кликнем на нее, то у нас эта ссылка откроется:

 1С 8.3. Оповещение пользователя.

Мы тоже можем сделать подобную ссылку, для этого нам надо всего лишь установить второй и третий параметр процедуры ПоказатьОповещениеПользователя():

&НаСервере
Функция ПолучитьСсылкуНаСправочник()
        возврат Справочники.Номенклатура.НайтиПоКоду("000000001");
КонецФункции


&НаКлиенте
Процедура Команда1(Команда)
        спр=ПолучитьСсылкуНаСправочник();
        Ссылочка=ПолучитьНавигационнуюСсылку(спр);
        ПоказатьОповещениеПользователя("Hello, World!", Ссылочка, строка(спр));
КонецПроцедуры

Во втором параметре мы указываем саму ссылку, для получения навигационной ссылки от ссылки на объем используем функцию ПолучитьНавигационнуюСсылку(). Третий параметр - это текст ссылки, в нашем случае это наименование элемента справочника, который откроется по ссылке.

Вот что у нас в итоге получиться:

1С 8.3. Оповещение пользователя.

Если ссылку не указать, то в качестве третьего параметра будет просто  пояснение:

1С 8.3. Оповещение пользователя.

В качестве четвертого параметра можно указать картинку:

&НаКлиенте
Процедура Команда1(Команда)
        спр=ПолучитьСсылкуНаСправочник();
        Ссылочка=ПолучитьНавигационнуюСсылку(спр);
        ПоказатьОповещениеПользователя("Hello, World!", Ссылочка, строка(спр),БиблиотекаКартинок.ОбщаяКартинка1);
КонецПроцедуры

Создать картинку можно в конфигураторе в ветке "Общие картинки":

1С 8.3. Оповещение пользователя.

Картинку можно тупо загрузить из файла:

1С 8.3. Оповещение пользователя.

И вот что у нас в итоге получиться:

1С 8.3. Оповещение пользователя.

См.  также Изучаем 1С 8.2. Урок 24. Сообщения пользователю, 1C 8.2 и 8.3 (УФ). Для чайников (платный раздел), 1C 8.2 Для чайников (бесплатный раздел)


Скриншоты, опубликованные в данной статье, являются цитатами и иллюстрациями   программного продукта "1C:Предприятие версия 8.2", авторское право на который принадлежит ЗАО 1С.. 


 

 
Пред. »
 
© 2020 Программирование - это просто
Joomla! - свободное программное обеспечение, распространяемое по лицензии GNU/GPL.
Русская локализация © 2005-2008 Joom.Ru - Русский Дом Joomla!
Design by Mamboteam.com | Powered by Mambobanner.de
Я принимаю Яндекс.Деньги